No announcement yet.

Cannot connect to virtual server

  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot connect to virtual server

    Hi all,

    Our team's app inventor was out of date so we went to download the most recent update at the following website: When we tried to import it into virtualbox, we got an error that said something like: "This appliance cannot be imported, the file already exists". So we uninstalled our out of date version of app inventor and tried again to re-install it. We got the same error, even though the newest version is the only one installed on our computer. We tried looking through the directory to find remnants of the old file to see if it was being called and causing errors, but we could not find anything, but I suppose that could make sense because the appliance was in virtualbox...

    Anyway, we are trying to install app inventor on a new computer, but it is a school PC. We cannot change its firewall settings. When I try to connect to the virtual server through the ftc appliance on the school computer, I cannot connect to it. I cannot ping it either. We encountered this problem before on a different computer, and we have been through three computers already in an attempt to get this working. All of the network settings are as they are given on the setup guide on the link above. Our tournament is this Saturday and we are pretty desperate for a solution.

    Thanks so much!!

  • #2
    Hi clairelaffan,

    On your original computer, the one that had the App Inventor installed, are you able to delete the old appliance file through the VirtualBox interface? Before you attempt to remove anything, have you made backup copies of your App Inventor project files? You can save them as .aia files from the App Inventor user interface (on the web browser). Once you have made backup copies of all of your projects, you can try to remove the virtual appliance.

    In the VirtualBox interface, if you right mouse click on the appliance file, you should see a "Remove" option from the pop up menu. The following shows this on a Mac:

    If you select the "Remove" menu item, a dialog box should appear and ask you if you just want to remove the appliance file from the list of machines on your VirtualBox software, or if you want to remove virtual machine and delete the files for the remote machine. I typically do "delete the files for the remote machine.

    After you successfully removed the file, you should be able to reimport the new appliance file.

    If you would like to use your other PC's (such as the school PC) and you are having an issue connecting to the virtual server, you might want to consider using an alternate method of configuring the virtual IP adapter. A mentor on this forum (TheOldPresbyope) posted a way to use the NAT settings in VirtualBox to enable port forwarding on a Windows PC. It seems that for many PCs, this port forwarding configuration works better than the host only IP adapter setup that is described in the original FTC MIT App Inventor install guide.

    Here's a link to TheOldPresbyope's original post:

    Last edited by Tom Eng; 02-10-2016, 10:05 AM.