Announcement

Collapse
No announcement yet.

Linear Op Mode autonomous program not appearing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linear Op Mode autonomous program not appearing

    The other day I created a program for the autonomous period, and the program would not appear in the menu of the RC app. I downloaded the program as normal, then downloaded to the phones, but the program would not appear. My coach, other teams and I have reviewed the software and program and not found any errors. Has anyone had this problem/ know how to fix it? Thanks!

  • #2
    Originally posted by FTC9026 View Post
    The other day I created a program for the autonomous period, and the program would not appear in the menu of the RC app. I downloaded the program as normal, then downloaded to the phones, but the program would not appear. My coach, other teams and I have reviewed the software and program and not found any errors. Has anyone had this problem/ know how to fix it? Thanks!
    Have you commented out the @Disabled annotation? This should be right before your Class declaration.
    Code:
    // @Disabled
    public class ClassName extends LinearOpMode {

    Comment


    • #3
      Originally posted by FTC8767 View Post
      Have you commented out the @Disabled annotation? This should be right before your Class declaration.
      Code:
      // @Disabled
      public class ClassName extends LinearOpMode {
      I believe OP is using App Inventor. I don't personally use it, but this post says that, in order to register an OpMode, you "While in designer mode select the op mode in the components section then place a checkmark in the box for autonomous which is in the properties section."

      Comment


      • #4
        Originally posted by GearTicks View Post
        I believe OP is using App Inventor.
        Oops! Sorry - I should have checked what forum it was.

        Comment

        Working...
        X