No announcement yet.

Odd Error and no voltage showing on Driver Station

  • Filter
  • Time
  • Show
Clear All
new posts

  • Odd Error and no voltage showing on Driver Station

    Symptoms: When our robot starts up there is no voltage shown on the Drive Station phone. When we initialize our opmode we get "uncaught exception: can't find serv-x." Always the same servo. What's odd is that we can fix it consistently by going to configuration, either activating or opening/canceling out of configuration (no changes made in either case) and restarting the robot. On the second initialization it will work fine, every time AND the voltage is showing on driver station once we do this.

    We have been troubleshooting for a while and are sure that configuration is correct, have swapped out cables, servos, servo ports, servo controllers, CPM and batteries. We have also swapped phones: the error seemed to appear first on this year's Moto G3 and not on last year's ZTE phones but is now happening to both. We are using the 11/13/16 version of AppInventor. Still not sure if it is a hardware or software issue but I tried going back to older software versions (from before the problem arose) and now THOSE throw the error as well.

    Any help or suggestions are appreciated: we compete in two weeks and know we can't touch the phone between autonomous/driver periods and this could stop us dead!

  • #2
    Turns out it was a corrupted configuration: I made a copy of the config and now it work fine, with voltage showing up before init as it should. YAY!