No announcement yet.

FCS doesn't run program

  • Filter
  • Time
  • Show
Clear All
new posts

  • FCS doesn't run program


    We've struggling getting the FCS to run our teleop program. Our workflow:
    1. Deploy our teleop program to the NXT
    2. Open Program Chooser on our NXT and select our teleop
    3. Connect the NXT to the Samantha and power the robot on
    4. Open up the FCS and find our NXT brick
    5. Disable autonomous and start match.

    The timer starts decreasing, yet our robot doesn't respond to anything. We don't know what's really going on here.

    Any ideas?


  • #2
    Is the FCS set up for your joysticks correctly? Also, are you using LabVIEW or RobotC?
    Max Bareiss

    FTC #248 Fatal Error (2009-2013)
    FRC #3142 Aperture (2009-2012)
    FRC #1302 Team Lionheart (2012-2013)
    ZRHS #89 Team K├╝hlschrank (2011-2013)
    ZRAC #40 Catcher in the Skye (2012)
    ISR 12: Umptysquatch 6
    Rowan University Baja SAE

    And mentoring for life.
    11 seasons of FIRST in 6 years, as a student. Many more as a mentor.


    • #3

      We will be able to get this fixed for you as soon as you arrive for the Qualifier. We have a practice field set up (all week) and an FCS running. There could be any number of things going on,but I'm sure we can work it out quickly

      We can post the answer here when we figure it out - to help other teams.

      Sincerely, ''Dutch 200'


      • #4
        Hey guys! We are having the same problem with our robot. Would it be possible to post the solution? Any help would be greatly appreciated!


        • #5
          By the time they arrived they had it worked out, not sure if there was a definitive answer.

          Suggestion #1: After running Program Chooser, try restarting the NXT. Some teams have found this necessary.

          Of course, your LabVIEW is completely updated right? (LabVIEW f5, NXT Module f3, and MCT Toolkit f1) You might try re-installing the MCT Toolkit if your LabVIEW was not at f5 when you initially installed the toolkit.


          • #6
            Yeah everything is up-to-date. I have even uninstalled everything and reinstalled it. I tried restarting the NXT and still no movement, then I restarted the entire robot and still nothing happened. It is weird because the robot runs perfectly when we test it in LabView on the teleop mode and our controls program. And the NXT says "###Enabled###" both in LabView and in the FCS software. If you have any other suggestions they would be worth a try.


            • #7
              You're the second team I've heard of that's currently struggling with this. I can only imagine that the FTCconfig.txt file might be the issue here. Can you see that a FTCconfig.txt file is on the NXT?

              We have had this type of thing occur intermittently, but found that restarting things, and reconnecting to the NXT remdied it - I'm sure you've done that a million times by now.


              • #8
                Yeah. I checked the NXT terminal and it said it is there. Do you think I should delete the and and deploy the piano song program again?


                • #9
                  Displaying the FTCconfig.txt contents

                  It will be useful to actually see what's inside the FTCconfig.txt file. Please look at this post I've made to the forum. I have shared a screen shot of a VI that lets you see what's in the FTCconfig.txt file, so you can build your own program. It is a 'computer target' and run in direct mode. I have also attached the actual VI for use. If you need help in knowing how to use this, just ask.

         post #10 in that thread

                  NOTE: Post #10 - I edited it and now it is awaiting approval....if you don't see it on the site, and need this right away Private message me and I can email you the files. The screen shot is below.

                  You will find the 'Read NXT File' vi here: Functions Palette - NXT I/O - DirectOnly - (bottom row left)
                  You make the string variable by right clicking on the front panel and choosing 'string indicator'' - consider extending the size of the box to dipslay more characters.
                  Last edited by FTC5666; 01-01-2014, 01:06 AM. Reason: re: Post #10 disappearing on the ni site


                  • #10
                    When I was trying to open it I ran into a little problem. For some reason it could not find the file "test.lvrbt" that is needed for the program. Is this a problem?


                    • #11
                      Sorry about that, that's the project I made it in...I wasn't sure how well that was going to work to share just a VI like that.

                      You should try doing a 'select-all/copy/paste' of it when you open it. Enter your Project, create a 'NEW VI targeted to the COMPUTER' and paste it there. That should work.

                      I use the copy/paste approach most of the time, it seems to work well. (for example, when I go get the 'autonomuous' template to pull into my project)

                      Otherwise, you could also build it yourself based on the .jpg
                      Last edited by FTC5666; 12-31-2013, 02:00 PM. Reason: 'target to the COMPUTER'


                      • #12
                        I cannot access the link, so I tried to message you but it said there was an error. My email is [email protected][dot]com
                        If you could send me the file that would be great.


                        • #13
                          Hi, there,

                          I am having the similar problem with SamoFCS: my robot is not getting any joystick setting changes. In my case, SamoFCS is able to start my TeleOp program, enter its main loop, but the system is not passing any joystick control to the robot.

                          Here is what I did:

                          1. Made sure my teleop programs runs well from RobotC's "Robot => NXT Brick => JoyStick Control - FTC". It works perfectly there. I let it go through all three stages: (A) TeleOp - Ready, (B) TeleOp - Running and (C) All Stopped. Everything worked fine. There is a program chooser.
                          2. Made sure the teleop program is set with the "Program Chooser".
                          3. Use PlayTone() in the main loop with incremented frequency (and wrap) to make sure the program is running.

                          Using SamoFCS, I also skip the autonomous period (BTW, autonomous program works fine), jump right into TeleOp. From the NXT screen, I can see it's running the right program, going through the initialization, and entering the main loop. I can hear the tone changing, so everything is working except the program is not getting any joystick control feeds.

                          The main loop is pretty simple, the start looks like this:

                          // Main control loop by the twin joystick controller.
                          // test only
                          if (freq > 5000)
                          freq = 780;
                          PlayTone(freq, 15);
                          freq = freq + 5;

                          // Read joystick controller values: joysticks, buttons, and triggers

                          // Move the robot around with good range sensitivity
                          motor[motorD] = 0.5 * joystick.joy1_y1;
                          motor[motorE] = 0.5 * joystick.joy1_y2;

                          In this case, the motor just joystick feed for some reason.

                          Any help will be greatly appreciated.


                          • #14
                            FCS Joystick 'Assign Controllers'

                            Have you performed the 'setup joysticks' in the FCS ? You need to press a button on the corresponding joystick when the FCS booming voice says 'Red 1 Driver 1', etc...

                            This sounds obvious to most, but I have encountered 2 teams where this was the final solution.

                            NOTE: Page 5 of the FCS Team User guide covers controller setup. The document can be found on the FIRST FTC site under Team Resources

                            The “?” indicates the system is waiting to know which controller will be associated with
                            Red Team 1, Driver 1. Press any button on the appropriate control to configure.

                            There are some other trouble-shooting steps we could go through if this doesn't fix it for you.
                            Last edited by FTC5666; 01-07-2014, 06:56 AM.


                            • #15
                              That's it! I thought by clicking OK in the setup page is good enough, now I know I have to use controller button as well. Thanks again!