Announcement

Collapse
No announcement yet.

Control Hub strangeness re webcam and VuForia

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Control Hub strangeness re webcam and VuForia

    I took a vuforia vumark detection program that works with expansion hub and RC phone camera and made some updates to support control hub and webcams. I used an MS Lifecam 3000 for testing. This worked but the orientation and aspect ratio was incorrect. Tried setting the desired aspect ratio in the vuforia parameters but received a strange error when I ran the program. So I took out the change to the parameters expecting things to go back to working though with the picture issues mentioned above. However I continued to get a very strange error and no go. I did not record the error because at the same time the bot battery ran down and I thought the error could be lack of juice. So I charged battery and started over. However the program still would not run and now kept failing with exception "vuforia initialization failed". Tried some things but nothing helped then reached end of day. Today, trying to start at the beginning and work through the problem I am now unable to deploy my code to the control hub. The APK push just hangs. Also seeing unexpected connection drops by the hub. Since I can't update the code, debugging the webcam problem is stalled. Things were going pretty well with the CH until I tried setting the aspect ratio in the parameters. Since that compile, the program has not worked and now failure to download APK is a real show stopper. I may have to reinstall the OS and RC program to refresh the hub as I don't know what else to try.

  • #2
    Ok. So the "vuforia failed to initialize" turned out to be the API key was old and did not support external cameras. Never mind that it worked for one day (although the strange aspect and orientation problem was due to the old key) and I had to dig through the logs to find this out. Seems if you are going to throw an exception for that reason...you would include that reason in the exception text.

    Now as to the ADB push of the apk hanging...after many retries reboots etc, it just started working. Seems all better now. No clue what happened there...

    Comment

    Working...
    X