Technology Forum Has Moved!

The FIRST Tech Challenge Technology forum has moved to a new location! Please take a look at our forum blog for links and instructions on how to access the new forum.

The official blog of the FIRST Tech Challenge - a STEM robotics programs for students grades 7-12.

Note that volunteers (except for FTA/WTA/CSA will still access their role specific forum through this site. The blog also outlines how to access the volunteer forums.
See more
See less

Something wrong with SDK 3.2 push

  • Filter
  • Time
  • Show
Clear All
new posts

  • Something wrong with SDK 3.2 push

    So, I was excited to try out the OnBot Java in SDK 3.2..... I pulled in the latest changes from the beta repo, and immediately noticed something odd: the AndroidManifest.xml still says it's v3.1...... I also used the Github web file viewer to confirm this.

    I decided to try it anyway though. After it finished installing on the phone, I opened programming mode and pointed my browser to the IP address.... and it's no different than before. No traces of OnBot Java.

    So, I think it's fairly obvious that something got screwed up in the commit that pushed v3.2....

  • #2
    The rest of the new SDK has been pushed out.


    • #3
      Originally posted by dmssargent View Post
      The rest of the new SDK has been pushed out.
      Well now I get several compile errors:

      Screenshot from 2017-08-02 22-10-31.png


      • #4
        You might need to try rebuilding your project (Build -> Rebuild Project in Android Studio), but with a fresh copy of the SDK, it builds successfully.


        • #5
          I just downloaded the beta 3.2 1/2 hour ago. I get the same errors and I tried rebuilding, it didn't help.


          • #6
            I am not sure why right now, but the rebuild is actually fully cleaning the project. Try deleting the directories: ftc_app/build, ftc_app/FtcRobotController/build, ftc_app/TeamCode/build, and then resync Gradle.

            If you use Git, you can use the following command instead of manually deleting directories:
            git clean -fdX


            • #7
              I deleted the build directories, then went to tools android sync. Still doesn't work.


              • #8
                Hi Folks,

                Thanks for catching this error. The problem should be rectified now. I apologize for mishandling this beta release. Thanks again for catching the error. The beta and alpha branches should now have a buildable and runnable version of the project folder. Please let me know if you spot additional issues.