Technology Forum Has Moved!

The FIRST Tech Challenge Technology forum has moved to a new location! Please take a look at our forum blog for links and instructions on how to access the new forum.


Note that volunteers (except for FTA/WTA/CSA will still access their role specific forum through this site. The blog also outlines how to access the volunteer forums.
See more
See less

Gamepad Connections

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Still more results from FirstOpmode: Back switch is on “X”. Same with other Logitech F310s; they also can control the Controller phone: quit Controller app, select and launch apps, etc. But none can register with Start-A. So we know the gamepad is getting information to the Controller phone. Both Driver phone and gamepad are directly connected to Power Distribution Module USB ports; no hub is being used.


    • #17
      Originally posted by jrasor View Post
      Both Driver phone and gamepad are directly connected to Power Distribution Module USB ports; no hub is being used.
      The driver phone should not be connected to the PDM. The PDM should be connected only to the robot controller phone and the control modules. The driver phone should be connected to the gamepads, through a hub if you want to use more than 1. The two phones should only be connected over Wi-Fi Direct.


      • #18
        Thanks, GearTicks. Tried your arrangement: Driver phone and gamepad connected by hub, Controller phone connected to PDM. Same result. With both arrangements, the game pad can control the Controller phone (quit Controller or any other app, select another, launch it). The game pad does not get registered by Start-A in either arrangement. Game pad is new, right out of the plastic tub. I've also tested it with testjs-gtk. It and our other 3 are all good by that test.

        Does any app besides the Driver app have to be running in order for the gamepad to be registered with Start-A? Does some other app block it?

        What does "Start-A" mean? Hold Start and tap A? Hold both Start and A? Hold Start then hold A? Hold how long? As you can see in my Question 2 above, I've tried lots of button gestures. Nada.


        • #19
          You hold <start> and tap <A>


          • #20
            5294-jjkd's minimal setup on Driver phone only, direct to gamepad with the right-angle OTG to female USB: works. Gesture: hold Start and tap A. This simple test requires only a Driver phone and the gamepad, and removes a potentially bad hub from consideration.


            • #21
              I think Thread 7034 covers this nicely.