Announcement

Collapse
No announcement yet.

Moto E4 Phones Disconnecting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Ok thanks... We have a several Motorola Moto G 2nd Gen phones. If we use the Moto G 2nd Gen phones for the DS and the Moto G5 or G5 Plus phones for the RC, the workaround is not needed. We won't be able use 5 GHz, but we will be able to use 2.4 GHz without the workaround. Is this correct?

    Comment


    • #32
      Also, if you change the Wi-Fi frequency band setting on the Moto G5 Driver Station phone to 5 GHz only (or 2.4 GHz only), would this resolve the issue?
      You do not have permission to view this gallery.
      This gallery has 1 photos.

      Comment


      • #33
        Originally posted by Alec View Post
        Ok thanks... We have a several Motorola Moto G 2nd Gen phones. If we use the Moto G 2nd Gen phones for the DS and the Moto G5 or G5 Plus phones for the RC, the workaround is not needed. We won't be able use 5 GHz, but we will be able to use 2.4 GHz without the workaround. Is this correct?
        Hi Alex,

        Yes, to the best of our knowledge yes, if you use the older phones as the Driver Stations you should not need the workaround.

        Also, thank you for the tip on the Wi-Fi Frequency Band. Perhaps by setting it to one band or the other it might resolve the issue! GREAT suggestion! We'll test this.

        Tom

        Comment


        • #34
          Alec,

          Do you only see that "Wi-Fi Frequency Band" option on the E4 phones? I do not see that setting on my E5 phone (which is also a dual-band phone).

          Tom

          Comment


          • #35
            Originally posted by Tom Eng View Post
            Alec,

            Do you only see that "Wi-Fi Frequency Band" option on the E4 phones? I do not see that setting on my E5 phone (which is also a dual-band phone).

            Tom
            I don't have an Moto E4 or G5. I have a Motorola Droid Turbo (XT1254) running Android 6.0.1 (i.e. non-FTC phone).

            The "Wi-Fi frequency band" setting on the Droid Turbo is located at [ Settings / Wi-Fi / ... / Advanced / Wi-Fi frequency band ].

            Comment


            • #36
              Originally posted by Tom Eng View Post

              Yes, to the best of our knowledge yes, if you use the older phones as the Driver Stations you should not need the workaround.

              Also, thank you for the tip on the Wi-Fi Frequency Band. Perhaps by setting it to one band or the other it might resolve the issue! GREAT suggestion! We'll test this.

              Tom

              Out of curiosity, is the workaround still needed for the 5.0 (Skystone) version of the app? I've looked at the README/ChangeLog to see if this problem has been addressed but wasn't able to find any mentions of it.

              Thanks!

              Pm

              Comment


              • #37
                Originally posted by FTC7172 View Post


                Out of curiosity, is the workaround still needed for the 5.0 (Skystone) version of the app? I've looked at the README/ChangeLog to see if this problem has been addressed but wasn't able to find any mentions of it.

                Thanks!

                Pm
                The workaround is no longer needed in v5.x https://github.com/FIRST-Tech-Challe...ster/README.md

                Comment


                • #38
                  Originally posted by 4634 Programmer View Post

                  The workaround is no longer needed in v5.x https://github.com/FIRST-Tech-Challe...ster/README.md
                  To clarify - v 5.x software has a keep alive feature. If it detects that the phone is a motorola phone, and it has a 5GHz radio, then the software sends additional keep alive messages during a match (when an op mode is initialized and when it's running) to suppress the scan feature of the motorola phones.

                  Unfortunately,Motorola phones still will "commandeer" the wifi radio and use it to scan the spectrum (2.4GHz and 5GHz ranges) if it thinks the radios are free/unused. The changes in v5.0 should prevent this from happening during a match when the Robot is in an initialized or active state.

                  However, I believe that during idle times (when you do not have an op mode initialized or running) the apps do not send the keep alive (to conserve bandwidth). I believe that it's possible that you might on rare occasion hear the motorola phones momentarily disconnect then reconnect when they are idle and I suspect that it's due to this scan feature from the manufacturer (which unfortunately we cannot control).
                  Last edited by Tom Eng; 08-01-2019, 10:41 AM.

                  Comment


                  • #39
                    Hey Everyone,

                    This post seems super helpful but we are a new team with two E4 phones and we can't even get them to stay connected long enough to program an op mode, much less run one. They will connect, stay connected for about 5 seconds then disconnect. This runs on about a 45 second cycle as the DS searches for the RC then finally finds it again. Any thoughts or help would be greatly appreciated!

                    Thanks in advance!

                    Comment


                    • #40
                      Originally posted by Harperbot View Post
                      Hey Everyone,

                      This post seems super helpful but we are a new team with two E4 phones and we can't even get them to stay connected long enough to program an op mode, much less run one. They will connect, stay connected for about 5 seconds then disconnect. This runs on about a 45 second cycle as the DS searches for the RC then finally finds it again. Any thoughts or help would be greatly appreciated!

                      Thanks in advance!
                      Hi Harperbot -

                      When you are working with your E4 phones, would you happen to be working in a school or similar institutional building? Do the phones stay connected if you try using them, for example, at home (away from the school or institution), or for example outside of the building (and away from any of the building's indoor or outdoor wireless access points)?

                      Here are some things to consider:

                      1. If you haven't already, check out this online tutorial which steps you through the phone configuration and pairing process.
                      2. If the phones were configured properly according to the instructions in the tutorial, and they stay connected when they are far enough away from the building and its wifi access points, is it possible that your school or building has a WiFi Blocker enabled?

                      The scenario you describe sounds like there might be a WiFi Blocker in your venue. If there is one, you will have to work with your building's IT staff to disable this function.

                      FIRST has received a lot of credible reports of WiFi Blockers in schools lately. I believe one of the most popular institutional hardware from Cisco (its Meraki hardware) has this WiFi Blocking feature enabled by default. Although the FCC in the US deemed WiFi Blocking to be illegal, we still encounter this a lot (both FTC and FRC) especially at schools. I just helped a couple of teachers within the past three months with identifying wifi blockers at their venues.

                      I hope this helps! Let us know what you find out. You might want to try and take your phones and laptop to an isolated spot away from any of your school's wifi access points and see if you can reliably connect and stay connected.

                      Tom

                      Comment


                      • #41
                        Hey Tom,

                        Sorry for the delay, we were on fall break. That was definitely the issue. I took the phones home last night and they connected instantly and stayed connected without issue. I will be talking to our IT department today. Thanks for the help!

                        Harper

                        Comment


                        • #42
                          Harperbot
                          Thanks for the update. These WiFi Blockers are becoming more and more common unfortunately. Hopefully your IT department can disable it for you or at least add the "192.x.x.x" IP address range to the "white list" to allow it to operate.

                          If you plan on hosting other FTC teams (or FRC teams) at your school, then the WiFi Blocker will need to be disabled for the event.

                          Good luck and have a fun season!

                          Tom

                          Comment

                          Working...
                          X