Technology Forum Has Moved!

The FIRST Tech Challenge Technology forum has moved to a new location! Please take a look at our forum blog for links and instructions on how to access the new forum.

The official blog of the FIRST Tech Challenge - a STEM robotics programs for students grades 7-12.

Note that volunteers (except for FTA/WTA/CSA will still access their role specific forum through this site. The blog also outlines how to access the volunteer forums.
See more
See less

OpenCV installation problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • FTC3491
    Can you check the log files? Do you see something like "UnsatisfiedLinkError"?

    If so, it's possible you haven't initialized OpenCV properly in FtcRobotControllerActivity. Follow the instructions in this .txt file:

    Leave a comment:

  • DanOelke
    started a topic OpenCV installation problem

    OpenCV installation problem

    I'm trying to learn a little about Vuforia and OpenCV. Got the demo opmode from FTC 3491 working (from their Part 4 video).

    Then added a bit of code to extract an rgb bitmap - (From Part 5 video). That worked fine.

    Then tried to do a bit of OpenCV processing - that is not working. It causes the robot app to crash. I tracked it down to the point where I am trying to create a "Mat" object. The log shows that it is failing in the Mat constructor - trying to call n_Mat(). The comment is that this is the call to the native interface. This is the first constructor for the first OpenCV object I am trying to use.

    So - any suggestions as to what I need to check in setting up OpenCV with Android Studio? Or is there something else I am missing?

    Thanks for any suggestions.