No announcement yet.

Problem importing project FtcRobotController-7.0

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem importing project FtcRobotController-7.0

    Have installed on Windows 10, Android Studio Artic Fox 2020.3.1 Patch 3, a Dell Laptop. Have downloaded, unzipped FtcRobotController-7.0 from github and have imported it to Android Studio. When right clicking on teamcode to create a new class, do not see an option for Java Class, see attachment 1. When I create a new project, I do see the option, see attachment . I have reloaded Android studio, restored the computer to factory including reinstalling windows and updatings. Any ideas on what I have to do to create a new JAVA class

    Thank you
    You do not have permission to view this gallery.
    This gallery has 2 photos.

  • #2
    Did your gradle build/sync succesfully complete? If it fails you won't be able to do anything in the project. Also, ensure that you imported the actual project folder, instead of the folder that contains it. When you unzip things the contents are often double foldered, and a common mistake is to import the outer folder instead of the inner one.


    • #3
      Gradle fails to sync and it says for an unknown reason. I have uninstalled AS and all Android studio associated files and directories. Have reinstalled AS. Downloaded FTCRobotController-7.0 zip file, unzipped it, and imported FTCRobotController-7.0 into AS, gradle runs for a few minutes and then says it failed for an unknown reason. Any thoughts on why it fails. I am doing everything as shown in the latest Android Studio Guide pdf from the First website. The only difference is not using Skystone that is in the guide, which is two versions older of the FTCcontroller. In the past tried skystone with the same results.

      A month ago I did the same thing on my personal Dell laptop and it worked perfectly. The computer I am trying to install on is the Robot Club Dell laptop, A latitude 3590.


      • #4
        Hi Jeff, as a sanity check, try running Android Studio in a clean Windows or Ubuntu guest OS using VMware or VirtualBox.


        • #5
          Alex and Lunerwalker2, thank you so much for your suggestions. Turns out the problem was that AS did not download the licenses with AS. The licenses are stored in the SDK folder. I copied the licenses from my personal computer to the club computer and now it works. No idea why the licenses were downloaded for my personal computer but not for the club computers.

          again thank you for the suggestions.


          • #6
            Yes, this is a common issue when you are importing a project after a new install of Android Studio.

            For future reference: by default, the SDK licenses for any new Android Studio install are not accepted. You must accept them by going to the SDK Manager in the top right corner of the screen in the list of icons:

            Then, in the list that appears, you need to check the box next to Android 9, API 29. Then click OK and accept the license when it appears, and let it download what it needs.

            Also for future reference, a lot (not all) of the resources for programming in Android Studio provided by FIRST, specifically the pdf guide in this case, can be quite outdated. There are much better guides for these things like the one on gm0 (
            You do not have permission to view this gallery.
            This gallery has 1 photos.