Announcement

Collapse
No announcement yet.

Teliop Selection

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Teliop Selection

    I made a program on my laptop, and then saved the program to the Robot Controller phone. When I go to select the Teliop on the Driver Controller phone, the program that I created is not given as an option. What can I do to fix this?

  • #2
    Which environment did you use to write the program? Android Studio or App Inventor? (Assuming not Blocks or onBot Java, since you mentioned writing it on your laptop...)

    Comment


    • #3
      I used Blocks.

      Comment


      • #4
        Most web browsers will allow you to continue editing a Blocks program even if it has lost its connection to the Robot Controller phone. You may not notice the disconnect until you try to save your changes. When you saved your Blocks program did you receive a confirming "Save Completed Successfully" in green towards the top of the screen?

        Comment


        • #5
          Yes, when I saved the program I received a "Save Completed Successfully". It appeared to the right of "Save Op Mode" button.

          Comment


          • #6
            Good. In that case the new op mode should appear in the list that you get when you you touch the triangle that is above and to the right of the INIT button on the Driver Station (DS) phone. The main thing that would prevent this from happening is if the two phones are not paired or if the DS phone has lost its connection to the Robot Controller (RC) phone. Does the DS phone show the RC phone's name under Network in the middle circle and a ping value of 3 to 30 ms under Ping in the right circle?

            Comment


            • #7
              When I open the list of op modes, the new op mode that I created is not listed as an option. It gives me options of old op modes already created, but not the new one. The phones are connected as there is a ping circle on the DS that has a ping value. The phones also say that they are paired.

              Comment


              • #8
                Originally posted by CM4283 View Post
                When I open the list of op modes, the new op mode that I created is not listed as an option. It gives me options of old op modes already created, but not the new one. The phones are connected as there is a ping circle on the DS that has a ping value. The phones also say that they are paired.
                file -> settings -> Build, Execution , Deployment -> Instant Run make sure that it is disabled
                also make sure you have the @TeleOp(name = "InsertNameHere") or @Autonomous(name = "InsertNameHere")annotation and that you do not have the @Disabled annotation

                Comment


                • #9
                  Do I go to the file and settings in the DS phone, or RC phone, or elsewhere?

                  Comment


                  • #10
                    I think 100101 is referring to a Java feature. If I'm interpreting his/her message correctly, the equivalent for Blocks would be the Autonomous/Teleop drop-down on the blocks editing screen and the Enabled check box in the right-hand column on the screen where your op modes are listed.

                    Comment

                    Working...
                    X