Announcement

Collapse
No announcement yet.

Connecting the Expansion Hub to the Control Hub

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Connecting the Expansion Hub to the Control Hub

    To open up extra ports pur team has decided to use a REV Robotics Expansion Hub along with our Control Hub. Both are fully updated. After using the same connection proceedure as e previously used to connect to Expansion Hubs (connect power to first hub, then connect first hub to second hub; use RS485 to connect hubs between each other), we cannot get the Expansion Hub to appear under 'Configure Robot'; only the Control Hub is shown.

    How can the Expansion Hub be connected to the Control Hub?

  • #2
    I should also note, both the Expansion Hub and Control Hub firmware is up to date.

    Comment


    • #3
      What version of the Robot Controller Application is the Control Hub running? If not on 6.0 update the Control Hub's Robot Controller.
      Before heading to configuration via the Driver Station, what is the color of the LED on both the Control Hub and the Expansion Hub?
      If the Expansion Hub is not green with an intermittent blue blink, have you replaced the three-pin cable between the Control Hub and Expansion Hub?
      If the Expansion Hub is green with an intermittent blue blink, does it appear in the configuration menu on the driver station under the Control Hub Portal?

      Comment


      • #4
        Not sure if it applies, but a couple of years ago, we had something similar between two expansion hubs. 3pin cable was had wires flipped in wrong order. Check wire

        Comment


        • #5
          Have you made a new configuration file with the second hub connected and powered on? Currently, the software does not support adding an Expansion Hub to an existing configuration file.

          Comment


          • #6
            Originally posted by RevRobotics View Post
            What version of the Robot Controller Application is the Control Hub running? If not on 6.0 update the Control Hub's Robot Controller.
            This fixed the problem, thank you. I thought updating the OS would update the app but it does not. Thanks again.

            Comment


            • #7
              The Control Hub runs three separate pieces of software: the Control Hub OS, the Robot Controller app, and the REV Hub Firmware (which is the same firmware that runs on the Expansion Hub). I recommend using the REV Hardware Client to make sure that all three pieces of software are up-to-date.

              Comment


              • #8
                Originally posted by NoahAndrews View Post
                The Control Hub runs three separate pieces of software: the Control Hub OS, the Robot Controller app, and the REV Hub Firmware (which is the same firmware that runs on the Expansion Hub). I recommend using the REV Hardware Client to make sure that all three pieces of software are up-to-date.
                Is this software available for Linux?

                Comment


                • #9
                  Not at this time, but it's on the roadmap.

                  Comment

                  Working...
                  X