Announcement

Collapse
No announcement yet.

Connecting the Expansion Hub to the Control Hub

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • NoahAndrews
    replied
    Not at this time, but it's on the roadmap.

    Leave a comment:


  • dominic03
    replied
    Originally posted by NoahAndrews View Post
    The Control Hub runs three separate pieces of software: the Control Hub OS, the Robot Controller app, and the REV Hub Firmware (which is the same firmware that runs on the Expansion Hub). I recommend using the REV Hardware Client to make sure that all three pieces of software are up-to-date.
    Is this software available for Linux?

    Leave a comment:


  • NoahAndrews
    replied
    The Control Hub runs three separate pieces of software: the Control Hub OS, the Robot Controller app, and the REV Hub Firmware (which is the same firmware that runs on the Expansion Hub). I recommend using the REV Hardware Client to make sure that all three pieces of software are up-to-date.

    Leave a comment:


  • dominic03
    replied
    Originally posted by RevRobotics View Post
    What version of the Robot Controller Application is the Control Hub running? If not on 6.0 update the Control Hub's Robot Controller.
    This fixed the problem, thank you. I thought updating the OS would update the app but it does not. Thanks again.

    Leave a comment:


  • NoahAndrews
    replied
    Have you made a new configuration file with the second hub connected and powered on? Currently, the software does not support adding an Expansion Hub to an existing configuration file.

    Leave a comment:


  • FTC7253
    replied
    Not sure if it applies, but a couple of years ago, we had something similar between two expansion hubs. 3pin cable was had wires flipped in wrong order. Check wire

    Leave a comment:


  • RevRobotics
    replied
    What version of the Robot Controller Application is the Control Hub running? If not on 6.0 update the Control Hub's Robot Controller.
    Before heading to configuration via the Driver Station, what is the color of the LED on both the Control Hub and the Expansion Hub?
    If the Expansion Hub is not green with an intermittent blue blink, have you replaced the three-pin cable between the Control Hub and Expansion Hub?
    If the Expansion Hub is green with an intermittent blue blink, does it appear in the configuration menu on the driver station under the Control Hub Portal?

    Leave a comment:


  • dominic03
    replied
    I should also note, both the Expansion Hub and Control Hub firmware is up to date.

    Leave a comment:


  • dominic03
    started a topic Connecting the Expansion Hub to the Control Hub

    Connecting the Expansion Hub to the Control Hub

    To open up extra ports pur team has decided to use a REV Robotics Expansion Hub along with our Control Hub. Both are fully updated. After using the same connection proceedure as e previously used to connect to Expansion Hubs (connect power to first hub, then connect first hub to second hub; use RS485 to connect hubs between each other), we cannot get the Expansion Hub to appear under 'Configure Robot'; only the Control Hub is shown.

    How can the Expansion Hub be connected to the Control Hub?
Working...
X